# CVE-2020-11441: Other in n/a

> CRLF injection in phpMyAdmin login form allows reflection of carriage return and line feed sequences on error pages, though vendor deems it non-exploitable.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phpmyadmin-2020-11441, DEBIAN-CVE-2020-11441, GHSA-j2jx-6pcj-jfpf

## What is CVE-2020-11441?

CVE-2020-11441 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 31 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyAdmin 5.0.2 allows CRLF injection, as demonstrated by %0D%0Astring%0D%0A inputs to login form fields causing CRLF sequences to be reflected on an error page. NOTE: the vendor states "I don't see anything specifically exploitable.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-11441?

1 open source package ship an affected version, including phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin` | Bitnami | From 5.0.2 | 5.0.3 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2020-11441?

Upgrade phpmyadmin to 5.0.3 or later.

## Is CVE-2020-11441 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11441 exists.

Public exploit code:

- phpMyAdmin 5.0.2 - CRLF Injection (nuclei): http/cves/2020/CVE-2020-11441.yaml

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11441 and fix it if it is affected.

What it is: CVE-2020-11441 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 31 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11441 exists.

Affected packages and fixed versions:
- phpmyadmin (Bitnami): affected from 5.0.2; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11441/ (Markdown: https://insights.sbomify.com/CVE-2020-11441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11441
- OSV: https://osv.dev/vulnerability/CVE-2020-11441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11441/
Summaries are generated and may contain mistakes; the official description above is the record.
