CVE-2020-11456 Cross-site scripting in n/a

Medium 5.4 Published Updated

An attacker can inject malicious scripts into survey group settings, potentially leading to session hijacking or code execution in LimeSurvey.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-11456?

CVE-2020-11456 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 1 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

LimeSurvey before 4.1.12+200324 has stored XSS in application/views/admin/surveysgroups/surveySettings.php and application/models/SurveysGroups.php (aka survey groups).

Weakness: CWE-79

Which versions are affected by CVE-2020-11456?

1 open source package ship an affected version, including limesurvey. It affects 1 product.

PackageAffectedFixed in
limesurvey BitnamiAll versions4.1.12, 4.1.12, 4.1.13

Products include Limesurvey Limesurvey.

How do I fix CVE-2020-11456?

Upgrade limesurvey to a fixed version for your release line: 4.1.12 or 4.1.13.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-11456 being exploited?

There is no known exploitation of CVE-2020-11456 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

All Limesurvey Limesurvey vulnerabilities

Sources

Also known as BIT-limesurvey-2020-11456, GHSA-8xmq-9rgw-vxxv.

Is CVE-2020-11456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free