# CVE-2020-11538: Out-of-bounds read in Pillow

> Out-of-bounds reads in Pillow's SGI image parser allow attackers to cause denial of service or potentially execute code via malicious files.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-pillow-2020-11538, DEBIAN-CVE-2020-11538, GHSA-43fq-w8qq-v88h, PYSEC-2020-80, RHSA-2020:3299, RHSA-2020:3302, UBUNTU-CVE-2020-11538

## What is CVE-2020-11538?

CVE-2020-11538 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In libImaging/SgiRleDecode.c in Pillow through 7.0.0, a number of out-of-bounds reads exist in the parsing of SGI image files, a different issue than CVE-2020-5311.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-11538?

4 open source packages ship an affected version, including pillow. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 7.0.1 |
| `pillow` | PyPI | All versions | 7.1.0 |
| `pillow` | PyPI | All versions | 7.1.0 |
| `pillow` | PyPI | All versions | 7.1.0 |
| `python-pillow` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python-pillow-debuginfo` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python-pillow-debugsource` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python3-pillow` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python3-pillow-debuginfo` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python3-pillow-tk-debuginfo` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:5.1.1-11.el8_0 |
| `python-pillow` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |
| `python-pillow-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |
| `python-pillow-debugsource` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |
| `python3-pillow` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |
| `python3-pillow-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |
| `python3-pillow-tk-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:5.1.1-11.el8_1 |

Products: Canonical Ubuntu Linux, Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2020-11538?

Upgrade pillow to a fixed version for your release line: 7.0.1 or 7.1.0.

## Is CVE-2020-11538 being exploited?

There is no known exploitation of CVE-2020-11538 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11538 and fix it if it is affected.

What it is: CVE-2020-11538 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11538 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 7.0.1
- pillow (PyPI): affected all versions; fixed in 7.1.0
- pillow (PyPI): affected all versions; fixed in 7.1.0
- pillow (PyPI): affected all versions; fixed in 7.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11538/ (Markdown: https://insights.sbomify.com/CVE-2020-11538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11538
- OSV: https://osv.dev/vulnerability/CVE-2020-11538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11538/
Summaries are generated and may contain mistakes; the official description above is the record.
