# CVE-2020-11889: An issue was discovered in Joomla!


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-joomla-2020-11889, GHSA-cmg9-pf33-9q72

## What is CVE-2020-11889?

CVE-2020-11889 is a medium-severity vulnerability in Joomla Joomla\!, published on 21 Apr 2020. 

### Official description

An issue was discovered in Joomla! before 3.9.17. Incorrect ACL checks in the access level section of com_users allow the unauthorized deletion of usergroups.

## Which versions are affected by CVE-2020-11889?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 2.5.0 | 3.9.17 |

Products: Joomla Joomla\!.

## How do I fix CVE-2020-11889?

Upgrade joomla to 3.9.17 or later.

## Is CVE-2020-11889 being exploited?

There is no known exploitation of CVE-2020-11889 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11889 and fix it if it is affected.

What it is: CVE-2020-11889 is a medium-severity vulnerability in Joomla Joomla\!, published on 21 Apr 2020. 
Exploitation: There is no known exploitation of CVE-2020-11889 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 2.5.0; fixed in 3.9.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11889/ (Markdown: https://insights.sbomify.com/CVE-2020-11889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11889
- OSV: https://osv.dev/vulnerability/CVE-2020-11889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11889/
Summaries are generated and may contain mistakes; the official description above is the record.
