CVE-2020-11971 Improper Input Validation in Apache Camel

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2020-11971?

CVE-2020-11971 is a high-severity vulnerability in Apache Camel, published on 14 May 2020.

Official description

Apache Camel's JMX is vulnerable to Rebind Flaw. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.x, 3.0.0 up to 3.1.0 is affected. Users should upgrade to 3.2.0.

Which versions are affected by CVE-2020-11971?

6 open source packages ship an affected version, including org.apache.camel:camel, org.apache.camel:camel-core and org.apache.camel:camel-management. It affects 5 products.

PackageAffectedFixed in
org.apache.camel:camel MavenAll versions3.2.0
org.apache.camel:camel MavenAll versions3.2.0
org.apache.camel:camel-core MavenAll versions3.2.0
org.apache.camel:camel-core MavenAll versions3.2.0
org.apache.camel:camel-management MavenAll versions3.2.0
org.apache.camel:camel-management MavenAll versions3.2.0

Products include Apache Camel, Oracle Communications Diameter Intelligence Hub, Oracle Communications Diameter Signaling Router, Oracle Enterprise Manager Base Platform, Oracle Flexcube Private Banking.

How do I fix CVE-2020-11971?

Upgrade org.apache.camel:camel to 3.2.0 or later.

Is CVE-2020-11971 being exploited?

There is no known exploitation of CVE-2020-11971 in the wild and no public exploit code.

All Apache Camel vulnerabilities

Sources

Also known as ECHO-2b5a-688e-769f, GHSA-hfg5-xpvw-c9x4.

Is CVE-2020-11971 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free