CVE-2020-11973 Apache Camel Netty enables Java deserialization by default

Critical 9.8 Published Updated

Apache Camel Netty allows remote code execution via unsafe Java deserialization enabled by default, requiring users to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11973?

CVE-2020-11973 is a critical unsafe deserialization vulnerability in Apache Camel, published on 14 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Camel Netty enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.

Weakness: CWE-502

Which versions are affected by CVE-2020-11973?

2 open source packages ship an affected version, including org.apache.camel:camel-netty. It affects 4 products.

PackageAffectedFixed in
org.apache.camel:camel-netty MavenFrom 3.0.03.2.0
org.apache.camel:camel-netty MavenFrom 3.0.03.2.0

Products include Apache Camel, Oracle Communications Diameter Signaling Router, Oracle Enterprise Manager Base Platform, Oracle Flexcube Private Banking.

How do I fix CVE-2020-11973?

Upgrade org.apache.camel:camel-netty to 3.2.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2020-11973 being exploited?

There is no known exploitation of CVE-2020-11973 in the wild and no public exploit code.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-h79p-32mx-fjj9.

Is CVE-2020-11973 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free