{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.unomi:unomi. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11975 exists.","fix":"Upgrade org.apache.unomi:unomi to 1.5.4 or later.","what":"CVE-2020-11975 is a critical code injection vulnerability in Apache Unomi, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11975 and fix it if it is affected.\n\nWhat it is: CVE-2020-11975 is a critical code injection vulnerability in Apache Unomi, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11975 exists.\n\nAffected packages and fixed versions:\n- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.4\n- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11975/ (Markdown: https://insights.sbomify.com/CVE-2020-11975/index.md)","id":"CVE-2020-11975","markdown":"https://insights.sbomify.com/CVE-2020-11975/index.md","name":"CVE-2020-11975","record":{"aliases":["GHSA-v6fq-q792-j46j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Unomi","requires_auth":"none","summary":"Attackers can execute arbitrary code via OGNL scripting in Apache Unomi conditions, requiring immediate upgrade to secure the Java process.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"unomi","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2020-11-24","github_poc":1,"max_poc_stars":6,"metasploit":0,"nuclei":1,"refs":[{"date":"2020-11-24T05:23:42Z","kind":"github_poc","ref":"https://github.com/1135/unomi_exploit","stars":6,"title":"CVE-2020-11975 CVE-2020-13942"},{"date":null,"kind":"nuclei","ref":"http/cves/2020/CVE-2020-11975.yaml","stars":null,"title":"Apache Unomi - Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"Improper Input Validation in Apache Unomi","id":"CVE-2020-11975","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Wicket","id":"CVE-2020-11976"},"packages":[{"ecosystem":"Maven","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.unomi:unomi","purl":null,"source":"GHSA-v6fq-q792-j46j"},{"ecosystem":"Maven","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.unomi:unomi","purl":"pkg:maven/org.apache.unomi/unomi","source":"GHSA-v6fq-q792-j46j"}],"prev":{"headline":"Remote code execution in DolphinScheduler","id":"CVE-2020-11974"},"products":["Apache Unomi"],"published":"2020-06-05","related":[{"cvss_score":9.8,"headline":"Remote Code Execution in Apache Unomi","id":"CVE-2020-13942","kev_date_added":null,"published":"2020-11-24"},{"cvss_score":7.5,"headline":"Apache Unomi log injection","id":"CVE-2021-31164","kev_date_added":null,"published":"2021-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via OGNL scripting in Apache Unomi conditions, requiring immediate upgrade to secure the Java process.","url":"https://insights.sbomify.com/CVE-2020-11975/"}