# CVE-2020-11975: Improper Input Validation in Apache Unomi

> Attackers can execute arbitrary code via OGNL scripting in Apache Unomi conditions, requiring immediate upgrade to secure the Java process.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v6fq-q792-j46j

## What is CVE-2020-11975?

CVE-2020-11975 is a critical code injection vulnerability in Apache Unomi, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

## Which versions are affected by CVE-2020-11975?

2 open source packages ship an affected version, including org.apache.unomi:unomi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.unomi:unomi` | Maven | All versions | 1.5.4 |
| `org.apache.unomi:unomi` | Maven | All versions | 1.5.4 |

Products: Apache Unomi.

## How do I fix CVE-2020-11975?

Upgrade org.apache.unomi:unomi to 1.5.4 or later.

## Is CVE-2020-11975 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11975 exists.

Public exploit code:

- CVE-2020-11975 CVE-2020-13942 (github_poc): https://github.com/1135/unomi_exploit
- Apache Unomi - Remote Code Execution (nuclei): http/cves/2020/CVE-2020-11975.yaml

## Other vulnerabilities in Apache Unomi

- [CVE-2020-13942](https://insights.sbomify.com/CVE-2020-13942/): Remote Code Execution in Apache Unomi (critical 9.8)
- [CVE-2021-31164](https://insights.sbomify.com/CVE-2021-31164/): Apache Unomi log injection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11975 and fix it if it is affected.

What it is: CVE-2020-11975 is a critical code injection vulnerability in Apache Unomi, published on 5 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11975 exists.

Affected packages and fixed versions:
- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.4
- org.apache.unomi:unomi (Maven): affected all versions; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11975/ (Markdown: https://insights.sbomify.com/CVE-2020-11975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11975
- OSV: https://osv.dev/vulnerability/CVE-2020-11975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11975/
Summaries are generated and may contain mistakes; the official description above is the record.
