# CVE-2020-11978: Apache Airflow Command Injection

> Authenticated users can execute arbitrary commands via example DAGs in Apache Airflow unless examples are disabled in the configuration.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 18 Jan 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2020
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-airflow-2020-11978, GHSA-rvmq-4x66-q7j3, PYSEC-2020-14

## What is CVE-2020-11978?

CVE-2020-11978 is a high-severity command injection vulnerability in Apache Airflow, published on 16 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-11978?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `airflow` | Bitnami | All versions | 1.10.11 |

Products: Apache Airflow.

## How do I fix CVE-2020-11978?

Upgrade apache-airflow to 1.10.11rc1 or later. US federal agencies must fix it by 18 Jul 2022.

## Is CVE-2020-11978 being exploited?

Yes. Attackers have exploited CVE-2020-11978 in the wild since at least 18 Jan 2022.

Public exploit code:

- PoC of how to exploit a RCE vulnerability of the example DAGs in Apache Airflow <1.10.11  (github_poc): https://github.com/pberba/CVE-2020-11978
- Apache Airflow 1.10.10 - Example DAG Remote Code Execution (metasploit)
- Apache Airflow 1.10.10 - 'Example Dag' Remote Code Execution (exploitdb)
- Apache Airflow <=1.10.10 - Remote Code Execution (nuclei): http/cves/2020/CVE-2020-11978.yaml

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)
- [CVE-2022-38649](https://insights.sbomify.com/CVE-2022-38649/): Apache Airflow Pinot provider allowed Command Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11978 and fix it if it is affected.

What it is: CVE-2020-11978 is a high-severity command injection vulnerability in Apache Airflow, published on 16 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-11978 in the wild since at least 18 Jan 2022.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- airflow (Bitnami): affected all versions; fixed in 1.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11978/ (Markdown: https://insights.sbomify.com/CVE-2020-11978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11978
- OSV: https://osv.dev/vulnerability/CVE-2020-11978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11978/
Summaries are generated and may contain mistakes; the official description above is the record.
