# CVE-2020-11979: Code injection in Apache Ant

> An attacker can inject modified source files into the build process via insecure temporary file handling in the fixcrlf task.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2020
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-gradle-2020-11979, CLEANSTART-2025-TN67221, CLEANSTART-2026-QY29190, CLEANSTART-2026-RX54054, DEBIAN-CVE-2020-11979, GHSA-f62v-xpxf-3v68, GHSA-j45w-qrgf-25vm, MGASA-2021-0173, MINI-5842-mv2c-rxrq, MINI-fcgf-96vc-xr2r, MINI-m436-7q28-wmhh, UBUNTU-CVE-2020-11979

## What is CVE-2020-11979?

CVE-2020-11979 is a high-severity vulnerability in Fedoraproject Fedora, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so that only the current user was allowed to access them. Unfortunately the fixcrlf task deleted the temporary file and created a new one without said protection, effectively nullifying the effort. This would still allow an attacker to inject modified source files into the build process.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions)

## Which versions are affected by CVE-2020-11979?

3 open source packages ship an affected version, including org.apache.ant:ant and gradle. It affects 37 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ant:ant` | Maven | All versions | 1.10.9 |
| `org.apache.ant:ant` | Maven | All versions | 1.10.9 |
| `gradle` | Bitnami | All versions | 6.8.0 |

Products: Apache Ant, Fedoraproject Fedora, Gradle Gradle, Oracle Agile Engineering Data Management, Oracle Api Gateway, Oracle Banking Platform, Oracle Banking Treasury Management, Oracle Communications Unified Inventory Management, Oracle Data Integrator, Oracle Endeca Information Discovery Studio, Oracle Enterprise Repository, Oracle Financial Services Analytical Applications Infrastructure, Oracle Flexcube Private Banking, Oracle Primavera Gateway, Oracle Primavera Unifier, Oracle Real-Time Decision Server, Oracle Retail Advanced Inventory Planning, Oracle Retail Assortment Planning, Oracle Retail Category Management Planning \& Optimization, Oracle Retail Eftlink and 17 more.

## How do I fix CVE-2020-11979?

Upgrade org.apache.ant:ant to 1.10.9 or later.

## Is CVE-2020-11979 being exploited?

There is no known exploitation of CVE-2020-11979 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2026-78254](https://insights.sbomify.com/CVE-2026-78254/): Apache Ant: Path traversal in ftp and scp tasks allows arbitrary file write (high 7.4)
- [CVE-2020-1945](https://insights.sbomify.com/CVE-2020-1945/): Sensitive Data Exposure in Apache Ant (medium 6.3)
- [CVE-2021-36373](https://insights.sbomify.com/CVE-2021-36373/): Apache Ant TAR archive denial of service vulnerability (medium 5.5)
- [CVE-2021-36374](https://insights.sbomify.com/CVE-2021-36374/): Apache Ant ZIP, and ZIP based, archive denial of service vulerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11979 and fix it if it is affected.

What it is: CVE-2020-11979 is a high-severity vulnerability in Fedoraproject Fedora, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11979 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ant:ant (Maven): affected all versions; fixed in 1.10.9
- org.apache.ant:ant (Maven): affected all versions; fixed in 1.10.9
- gradle (Bitnami): affected all versions; fixed in 6.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11979/ (Markdown: https://insights.sbomify.com/CVE-2020-11979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11979
- OSV: https://osv.dev/vulnerability/CVE-2020-11979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11979/
Summaries are generated and may contain mistakes; the official description above is the record.
