# CVE-2020-11980: Server-Side Request Forgery in Karaf

> A viewer role can trigger SSRF and pollute the MBean registry via MLet, bypassing intended access controls in Apache Karaf.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9jg9-6wm2-x7p5

## What is CVE-2020-11980?

CVE-2020-11980 is a medium-severity server-side request forgery vulnerability in Apache Karaf, published on 12 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Karaf, JMX authentication takes place using JAAS and authorization takes place using ACL files. By default, only an "admin" can actually invoke on an MBean. However there is a vulnerability there for someone who is not an admin, but has a "viewer" role. In the 'etc/jmx.acl.cfg', such as role can call get*. It's possible to authenticate as a viewer role + invokes on the MLet getMBeansFromURL method, which goes off to a remote server to fetch the desired MBean, which is then registered in Karaf. At this point the attack fails as "viewer" doesn't have the permission to invoke on the MBean. Still, it could act as a SSRF style attack and also it essentially allows a "viewer" role to pollute the MBean registry, which is a kind of privilege escalation. The vulnerability is low as it's possible to add a ACL to limit access. Users should update to Apache Karaf 4.2.9 or newer.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-11980?

2 open source packages ship an affected version, including org.apache.karaf.management:org.apache.karaf.management.server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf.management:org.apache.karaf.management.server` | Maven | All versions | 4.2.9 |
| `org.apache.karaf.management:org.apache.karaf.management.server` | Maven | All versions | 4.2.9 |

Products: Apache Karaf.

## How do I fix CVE-2020-11980?

Upgrade org.apache.karaf.management:org.apache.karaf.management.server to 4.2.9 or later.

## Is CVE-2020-11980 being exploited?

There is no known exploitation of CVE-2020-11980 in the wild and no public exploit code.

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2022-40145](https://insights.sbomify.com/CVE-2022-40145/): Apache Karaf: JDBC JAAS LDAP injection (critical 9.8)
- [CVE-2018-11788](https://insights.sbomify.com/CVE-2018-11788/): XML External Entity Reference in Apache Karaf (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11980 and fix it if it is affected.

What it is: CVE-2020-11980 is a medium-severity server-side request forgery vulnerability in Apache Karaf, published on 12 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11980 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf.management:org.apache.karaf.management.server (Maven): affected all versions; fixed in 4.2.9
- org.apache.karaf.management:org.apache.karaf.management.server (Maven): affected all versions; fixed in 4.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11980/ (Markdown: https://insights.sbomify.com/CVE-2020-11980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11980
- OSV: https://osv.dev/vulnerability/CVE-2020-11980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11980/
Summaries are generated and may contain mistakes; the official description above is the record.
