CVE-2020-11981 Command injection via Celery broker in Apache Airflow

Critical 9.8 Published Updated

Attackers with broker access can inject commands into CeleryExecutor, leading to arbitrary code execution on Airflow workers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11981?

CVE-2020-11981 is a critical command injection vulnerability in Apache Airflow, published on 16 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.

Weakness: CWE-78

Which versions are affected by CVE-2020-11981?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions1.10.11rc1
apache-airflow PyPIAll versions1.10.11rc1
apache-airflow PyPIAll versions1.10.11rc1
airflow BitnamiAll versions1.10.11

Products include Apache Airflow.

How do I fix CVE-2020-11981?

Upgrade apache-airflow to 1.10.11rc1 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-11981 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11981 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2020-11981, GHSA-976r-qfjj-c24w, PYSEC-2020-15.

Is CVE-2020-11981 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free