# CVE-2020-11981: Command injection via Celery broker in Apache Airflow

> Attackers with broker access can inject commands into CeleryExecutor, leading to arbitrary code execution on Airflow workers.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-airflow-2020-11981, GHSA-976r-qfjj-c24w, PYSEC-2020-15

## What is CVE-2020-11981?

CVE-2020-11981 is a critical command injection vulnerability in Apache Airflow, published on 16 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attacker can connect to the broker (Redis, RabbitMQ) directly, it is possible to inject commands, resulting in the celery worker running arbitrary commands.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-11981?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `apache-airflow` | PyPI | All versions | 1.10.11rc1 |
| `airflow` | Bitnami | All versions | 1.10.11 |

Products: Apache Airflow.

## How do I fix CVE-2020-11981?

Upgrade apache-airflow to 1.10.11rc1 or later.

## Is CVE-2020-11981 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11981 exists.

Public exploit code:

- https://github.com/Evillm/CVE-2020-11981-PoC (github_poc): https://github.com/Evillm/CVE-2020-11981-PoC
- Apache Airflow <=1.10.10 - Command Injection (nuclei)

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11981 and fix it if it is affected.

What it is: CVE-2020-11981 is a critical command injection vulnerability in Apache Airflow, published on 16 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11981 exists.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- apache-airflow (PyPI): affected all versions; fixed in 1.10.11rc1
- airflow (Bitnami): affected all versions; fixed in 1.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11981/ (Markdown: https://insights.sbomify.com/CVE-2020-11981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11981
- OSV: https://osv.dev/vulnerability/CVE-2020-11981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11981/
Summaries are generated and may contain mistakes; the official description above is the record.
