CVE-2020-11982 Insecure default config of Celery worker in Apache Airflow

Critical 9.8 Published Updated

Attackers with broker access can inject malicious payloads causing remote code execution on Airflow workers using CeleryExecutor.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11982?

CVE-2020-11982 is a critical unsafe deserialization vulnerability in Apache Airflow, published on 16 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

Weakness: CWE-502

Which versions are affected by CVE-2020-11982?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions1.10.11
apache-airflow PyPIAll versions1.10.11
apache-airflow PyPIAll versions1.10.11rc1
airflow BitnamiAll versions1.10.11

Products include Apache Airflow.

How do I fix CVE-2020-11982?

Upgrade apache-airflow to a fixed version for your release line: 1.10.11 or 1.10.11rc1.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2020-11982 being exploited?

There is no known exploitation of CVE-2020-11982 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2020-11982, GHSA-9g2w-5f3v-mfmm, PYSEC-2020-16.

Is CVE-2020-11982 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free