# CVE-2020-11985: Security feature bypass in Apache HTTP Server

> Attackers can spoof IP addresses in logs and PHP scripts when using mod_remoteip with specific mod_rewrite rules, bypassing IP-based security controls.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-apache-2020-11985, DEBIAN-CVE-2020-11985, GHSA-39vm-h38v-j867, RHBA-2015:2194, UBUNTU-CVE-2020-11985

## What is CVE-2020-11985?

CVE-2020-11985 is a medium-severity vulnerability in Apache Http Server, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

IP address spoofing when proxying using mod_remoteip and mod_rewrite For configurations using proxying with mod_remoteip and certain mod_rewrite rules, an attacker could spoof their IP address for logging and PHP scripts. Note this issue was fixed in Apache HTTP Server 2.4.24 but was retrospectively allocated a low severity CVE in 2020.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2020-11985?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.1 | 2.4.24 |
| `httpd` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `httpd-devel` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `httpd-manual` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `httpd-tools` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `mod_ldap` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `mod_proxy_html` | Red Hat:enterprise_linux:7::client | All versions | 1:2.4.6-40.el7 |
| `mod_session` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.6-40.el7 |
| `mod_ssl` | Red Hat:enterprise_linux:7::client | All versions | 1:2.4.6-40.el7 |
| `httpd` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `httpd-devel` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `httpd-manual` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `httpd-tools` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `mod_ldap` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `mod_proxy_html` | Red Hat:enterprise_linux:7::computenode | All versions | 1:2.4.6-40.el7 |
| `mod_session` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.6-40.el7 |
| `mod_ssl` | Red Hat:enterprise_linux:7::computenode | All versions | 1:2.4.6-40.el7 |
| `httpd` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `httpd-devel` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `httpd-manual` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `httpd-tools` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `mod_ldap` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `mod_proxy_html` | Red Hat:enterprise_linux:7::server | All versions | 1:2.4.6-40.el7 |
| `mod_session` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.6-40.el7 |
| `mod_ssl` | Red Hat:enterprise_linux:7::server | All versions | 1:2.4.6-40.el7 |
| `httpd` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `httpd-debuginfo` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `httpd-devel` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `httpd-manual` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `httpd-tools` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `mod_ldap` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `mod_proxy_html` | Red Hat:enterprise_linux:7::workstation | All versions | 1:2.4.6-40.el7 |
| `mod_session` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.6-40.el7 |
| `mod_ssl` | Red Hat:enterprise_linux:7::workstation | All versions | 1:2.4.6-40.el7 |

Products: Apache Http Server.

## How do I fix CVE-2020-11985?

Upgrade apache to 2.4.24 or later.

## Is CVE-2020-11985 being exploited?

There is no known exploitation of CVE-2020-11985 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11985 and fix it if it is affected.

What it is: CVE-2020-11985 is a medium-severity vulnerability in Apache Http Server, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11985 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.1; fixed in 2.4.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11985/ (Markdown: https://insights.sbomify.com/CVE-2020-11985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11985
- OSV: https://osv.dev/vulnerability/CVE-2020-11985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11985/
Summaries are generated and may contain mistakes; the official description above is the record.
