# CVE-2020-11987: Server-side request forgery (SSRF) in Apache Batik

> An attacker can exploit improper input validation in Apache Batik to force the server to make arbitrary GET requests, potentially accessing internal resources.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2021
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2020-11987, GHSA-2h63-qp69-fwvw, MGASA-2021-0139, OESA-2021-1134, UBUNTU-CVE-2020-11987, openSUSE-SU-2024:12402-1

## What is CVE-2020-11987?

CVE-2020-11987 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Batik 1.13 is vulnerable to server-side request forgery, caused by improper input validation by the NodePickerPanel. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-11987?

2 open source packages ship an affected version, including org.apache.xmlgraphics:batik-svgbrowser. It affects 22 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlgraphics:batik-svgbrowser` | Maven | All versions | 1.14 |
| `org.apache.xmlgraphics:batik-svgbrowser` | Maven | All versions | 1.14 |

Products: Apache Batik, Debian Debian Linux, Fedoraproject Fedora, Oracle Agile Engineering Data Management, Oracle Banking Apis, Oracle Banking Digital Experience, Oracle Communications Application Session Controller, Oracle Communications Metasolv Solution, Oracle Communications Offline Mediation Controller, Oracle Enterprise Repository, Oracle Flexcube Universal Banking, Oracle Fusion Middleware Mapviewer, Oracle Instantis Enterprisetrack, Oracle Insurance Policy Administration, Oracle Product Lifecycle Analytics, Oracle Retail Back Office, Oracle Retail Central Office, Oracle Retail Order Broker, Oracle Retail Order Management System Cloud Service, Oracle Retail Point-of-Service and 2 more.

## How do I fix CVE-2020-11987?

Upgrade org.apache.xmlgraphics:batik-svgbrowser to 1.14 or later.

## Is CVE-2020-11987 being exploited?

There is no known exploitation of CVE-2020-11987 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2018-8013](https://insights.sbomify.com/CVE-2018-8013/): Deserialization of Untrusted Data in Apache Batik (critical 9.8)
- [CVE-2022-41704](https://insights.sbomify.com/CVE-2022-41704/): Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input (high 7.5)
- [CVE-2022-42890](https://insights.sbomify.com/CVE-2022-42890/): Apache Batik prior to 1.16 allows RCE via scripting (high 7.5)
- [CVE-2022-40146](https://insights.sbomify.com/CVE-2022-40146/): Jar url should be blocked by DefaultScriptSecurity (high 7.5)
- [CVE-2019-17566](https://insights.sbomify.com/CVE-2019-17566/): Server-side request forgery (SSRF) in Apache Batik (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11987 and fix it if it is affected.

What it is: CVE-2020-11987 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11987 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlgraphics:batik-svgbrowser (Maven): affected all versions; fixed in 1.14
- org.apache.xmlgraphics:batik-svgbrowser (Maven): affected all versions; fixed in 1.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11987/ (Markdown: https://insights.sbomify.com/CVE-2020-11987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11987
- OSV: https://osv.dev/vulnerability/CVE-2020-11987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11987/
Summaries are generated and may contain mistakes; the official description above is the record.
