# CVE-2020-12265: Path Traversal in decompress

> An attacker can write arbitrary files to the system via directory traversal in the decompress package when processing archives with symlinks.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qgfr-5hqp-vrw9, ROOT-APP-NPM-CVE-2020-12265

## What is CVE-2020-12265?

CVE-2020-12265 is a critical path traversal vulnerability in n/a, published on 26 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-12265?

2 open source packages ship an affected version, including decompress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decompress` | npm | All versions | 4.2.1 |
| `decompress` | npm | All versions | 4.2.1 |

Products: Decompress Project Decompress.

## How do I fix CVE-2020-12265?

Upgrade decompress to 4.2.1 or later.

## Is CVE-2020-12265 being exploited?

There is no known exploitation of CVE-2020-12265 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-39246](https://insights.sbomify.com/CVE-2026-39246/): Path traversal in n/a (high 7.5)
- [CVE-2026-39245](https://insights.sbomify.com/CVE-2026-39245/): Path traversal in n/a (medium 6.2)
- [CVE-2026-39243](https://insights.sbomify.com/CVE-2026-39243/): decompress allows arbitrary hardlink creation during archive extraction (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12265 and fix it if it is affected.

What it is: CVE-2020-12265 is a critical path traversal vulnerability in n/a, published on 26 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-12265 in the wild and no public exploit code.

Affected packages and fixed versions:
- decompress (npm): affected all versions; fixed in 4.2.1
- decompress (npm): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12265/ (Markdown: https://insights.sbomify.com/CVE-2020-12265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12265
- OSV: https://osv.dev/vulnerability/CVE-2020-12265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12265/
Summaries are generated and may contain mistakes; the official description above is the record.
