CVE-2020-12276 Cross-site scripting in n/a
Stored XSS in GitLab admin notifications allows attackers to execute scripts in admin sessions, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-12276?
CVE-2020-12276 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 29 Apr 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GitLab 9.5.9 through 12.9 is vulnerable to stored XSS in an admin notification feature.
Weakness: CWE-79
Which versions are affected by CVE-2020-12276?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 9.5.9 | 12.7.8, 12.8.8, 12.9.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-12276?
Upgrade gitlab to a fixed version for your release line: 12.7.8, 12.8.8 or 12.9.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-12276 being exploited?
There is no known exploitation of CVE-2020-12276 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-12276, GHSA-m77g-m5w2-j2f3, UBUNTU-CVE-2020-12276.