# CVE-2020-12439: Grin allows attackers to adversely affect availability of data on a Mimblewimble blockchain


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6x52-88cq-55q5

## What is CVE-2020-12439?

CVE-2020-12439 is a medium-severity vulnerability in n/a, published on 5 May 2020. 

### Official description

Grin before 3.1.0 allows attackers to adversely affect availability of data on a Mimblewimble blockchain.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2020-12439?

2 open source packages ship an affected version, including grin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grin` | crates.io | All versions | 3.1.0 |
| `grin` | crates.io | All versions | 3.1.0 |

Products: Grin Grin.

## How do I fix CVE-2020-12439?

Upgrade grin to 3.1.0 or later.

## Is CVE-2020-12439 being exploited?

There is no known exploitation of CVE-2020-12439 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-9195](https://insights.sbomify.com/CVE-2019-9195/): Path traversal in n/a (critical 9.8)
- [CVE-2020-15899](https://insights.sbomify.com/CVE-2020-15899/): Grin insufficient data validation (high 7.5)
- [CVE-2020-6638](https://insights.sbomify.com/CVE-2020-6638/): Grin Insufficient Validation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12439 and fix it if it is affected.

What it is: CVE-2020-12439 is a medium-severity vulnerability in n/a, published on 5 May 2020. 
Exploitation: There is no known exploitation of CVE-2020-12439 in the wild and no public exploit code.

Affected packages and fixed versions:
- grin (crates.io): affected all versions; fixed in 3.1.0
- grin (crates.io): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12439/ (Markdown: https://insights.sbomify.com/CVE-2020-12439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12439
- OSV: https://osv.dev/vulnerability/CVE-2020-12439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12439/
Summaries are generated and may contain mistakes; the official description above is the record.
