CVE-2020-12603 Denial of service in n/a
Attackers can cause excessive memory consumption and denial of service by sending HTTP/2 requests with many small data frames to Envoy proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-12603?
CVE-2020-12603 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 1 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy version 1.14.2, 1.13.2, 1.12.4 or earlier may consume excessive amounts of memory when proxying HTTP/2 requests or responses with many small (i.e. 1 byte) data frames.
Weakness: CWE-400
Which versions are affected by CVE-2020-12603?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.12.5, 1.13.3, 1.14.3 |
Products include Envoyproxy Envoy.
How do I fix CVE-2020-12603?
Upgrade envoy to a fixed version for your release line: 1.12.5, 1.13.3 or 1.14.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-12603 being exploited?
There is no known exploitation of CVE-2020-12603 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2020-12603, GHSA-pc38-4q6c-85p6.