CVE-2020-12605 Envoy version 1.14.2, 1.13.2, 1.12.4 or earlier may consume excessive amounts of memory when processing HTTP/1.1 headers with long field nam

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2020-12605?

CVE-2020-12605 is a high-severity vulnerability in Envoyproxy Envoy, published on 1 Jul 2020.

Official description

Envoy version 1.14.2, 1.13.2, 1.12.4 or earlier may consume excessive amounts of memory when processing HTTP/1.1 headers with long field names or requests with long URLs.

Weakness: CWE-770

Which versions are affected by CVE-2020-12605?

1 open source package ship an affected version, including envoy. It affects 1 product.

PackageAffectedFixed in
envoy BitnamiAll versions1.12.5, 1.13.3, 1.14.3

Products include Envoyproxy Envoy.

How do I fix CVE-2020-12605?

Upgrade envoy to a fixed version for your release line: 1.12.5, 1.13.3 or 1.14.3.

Is CVE-2020-12605 being exploited?

There is no known exploitation of CVE-2020-12605 in the wild and no public exploit code.

All Envoyproxy Envoy vulnerabilities

Sources

Also known as BIT-envoy-2020-12605, GHSA-fjxc-jj43-f777.

Is CVE-2020-12605 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free