{"answers":{"affected":"3 open source packages ship an affected version, including fastecdsa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-12607 in the wild and no public exploit code.","fix":"Upgrade fastecdsa to 2.1.2 or later.","what":"CVE-2020-12607 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-12607 and fix it if it is affected.\n\nWhat it is: CVE-2020-12607 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-12607 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastecdsa (PyPI): affected all versions; fixed in 2.1.2\n- fastecdsa (PyPI): affected all versions; fixed in 2.1.2\n- fastecdsa (PyPI): affected all versions; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-12607/ (Markdown: https://insights.sbomify.com/CVE-2020-12607/index.md)","id":"CVE-2020-12607","markdown":"https://insights.sbomify.com/CVE-2020-12607/index.md","name":"CVE-2020-12607","record":{"aliases":["GHSA-56wv-2wr9-3h9r","PYSEC-2020-42"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ECDSA library","requires_auth":"none","summary":"An attacker can cause valid ECDSA signatures to fail verification for specific keys, potentially enabling denial-of-service or bypassing authentication checks in dependent systems.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fastecdsa","vendor":"antonkueltz"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"An issue was discovered in fastecdsa before 2.1.2. When using the NIST P-256 curve in the ECDSA implementation, the point at infinity is mishandled. This means that for an extreme value in k and s^-1, the signature verification fails even if the signature is correct. This behavior is not solely a usability problem. There are some threat models where an attacker can benefit by successfully guessing users for whom signature verification will fail.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Verification of Cryptographic Signature in fastecdsa","id":"CVE-2020-12607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2020"},"n_packages":3,"n_references":4,"next":{"headline":"Misconfiguration in n/a","id":"CVE-2020-12608"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":null,"source":"GHSA-56wv-2wr9-3h9r"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":"pkg:pypi/fastecdsa","source":"GHSA-56wv-2wr9-3h9r"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":"pkg:pypi/fastecdsa","source":"PYSEC-2020-42"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2020-12606"},"products":["n/a"],"published":"2020-06-02","related":[{"cvss_score":7.5,"headline":"Uninitialized Variable in fastecdsa","id":"CVE-2024-21502","kev_date_added":null,"published":"2024-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can cause valid ECDSA signatures to fail verification for specific keys, potentially enabling denial-of-service or bypassing authentication checks in dependent systems.","url":"https://insights.sbomify.com/CVE-2020-12607/"}