# CVE-2020-12607: Improper Verification of Cryptographic Signature in fastecdsa

> An attacker can cause valid ECDSA signatures to fail verification for specific keys, potentially enabling denial-of-service or bypassing authentication checks in dependent systems.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-56wv-2wr9-3h9r, PYSEC-2020-42

## What is CVE-2020-12607?

CVE-2020-12607 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in fastecdsa before 2.1.2. When using the NIST P-256 curve in the ECDSA implementation, the point at infinity is mishandled. This means that for an extreme value in k and s^-1, the signature verification fails even if the signature is correct. This behavior is not solely a usability problem. There are some threat models where an attacker can benefit by successfully guessing users for whom signature verification will fail.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-12607?

3 open source packages ship an affected version, including fastecdsa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastecdsa` | PyPI | All versions | 2.1.2 |
| `fastecdsa` | PyPI | All versions | 2.1.2 |
| `fastecdsa` | PyPI | All versions | 2.1.2 |

Products: Antonkueltz Fastecdsa.

## How do I fix CVE-2020-12607?

Upgrade fastecdsa to 2.1.2 or later.

## Is CVE-2020-12607 being exploited?

There is no known exploitation of CVE-2020-12607 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-21502](https://insights.sbomify.com/CVE-2024-21502/): Uninitialized Variable in fastecdsa (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12607 and fix it if it is affected.

What it is: CVE-2020-12607 is a high-severity vulnerability in n/a, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-12607 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastecdsa (PyPI): affected all versions; fixed in 2.1.2
- fastecdsa (PyPI): affected all versions; fixed in 2.1.2
- fastecdsa (PyPI): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12607/ (Markdown: https://insights.sbomify.com/CVE-2020-12607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12607
- OSV: https://osv.dev/vulnerability/CVE-2020-12607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12607/
Summaries are generated and may contain mistakes; the official description above is the record.
