# CVE-2020-12642: XXE vulnerability in Launch import


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2jx8-v4hv-gx3h

## What is CVE-2020-12642?

CVE-2020-12642 is a high-severity vulnerability in n/a, published on 4 May 2020. 

### Official description

An issue was discovered in service-api before 4.3.12 and 5.x before 5.1.1 for Report Portal. It allows XXE, with resultant secrets disclosure and SSRF, via JUnit XML launch import.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-12642?

4 open source packages ship an affected version, including com.epam.reportportal:service-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.epam.reportportal:service-api` | Maven | From 3.1.0 | 4.3.12 |
| `com.epam.reportportal:service-api` | Maven | From 3.1.0 | 4.3.12 |
| `com.epam.reportportal:service-api` | Maven | From 5.0.0 | 5.1.1 |
| `com.epam.reportportal:service-api` | Maven | From 5.0.0 | 5.1.1 |

Products: Reportportal Service-Api.

## How do I fix CVE-2020-12642?

Upgrade com.epam.reportportal:service-api to a fixed version for your release line: 4.3.12 or 5.1.1.

## Is CVE-2020-12642 being exploited?

There is no known exploitation of CVE-2020-12642 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-29620](https://insights.sbomify.com/CVE-2021-29620/): XXE vulnerability on Launch import with externally-defined DTD file (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12642 and fix it if it is affected.

What it is: CVE-2020-12642 is a high-severity vulnerability in n/a, published on 4 May 2020. 
Exploitation: There is no known exploitation of CVE-2020-12642 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.epam.reportportal:service-api (Maven): affected from 3.1.0; fixed in 4.3.12
- com.epam.reportportal:service-api (Maven): affected from 3.1.0; fixed in 4.3.12
- com.epam.reportportal:service-api (Maven): affected from 5.0.0; fixed in 5.1.1
- com.epam.reportportal:service-api (Maven): affected from 5.0.0; fixed in 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12642/ (Markdown: https://insights.sbomify.com/CVE-2020-12642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12642
- OSV: https://osv.dev/vulnerability/CVE-2020-12642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12642/
Summaries are generated and may contain mistakes; the official description above is the record.
