CVE-2020-12648 Cross-site scripting vulnerability in TinyMCE
Remote attackers can inject arbitrary web script into TinyMCE when classic editing mode is enabled, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-12648?
CVE-2020-12648 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.
Weakness: CWE-79
Which versions are affected by CVE-2020-12648?
4 open source packages ship an affected version, including tinymce. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tinymce npm | All versions | 4.9.11 |
tinymce npm | All versions | 4.9.11 |
tinymce npm | From 5.0.0 | 5.4.1 |
tinymce npm | From 5.0.0 | 5.4.1 |
Products include Tiny Tinymce.
How do I fix CVE-2020-12648?
Upgrade tinymce to a fixed version for your release line: 4.9.11 or 5.4.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-12648 being exploited?
There is no known exploitation of CVE-2020-12648 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2026-47759 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- CVE-2026-47760 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
- CVE-2026-47761 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- CVE-2026-47762 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
- CVE-2024-21908 Cross-site scripting vulnerability in TinyMCE
Sources
Also known as GHSA-vrv8-v4w8-f95h, UBUNTU-CVE-2020-12648.