CVE-2020-12689 OpenStack Keystone EC2 and/or credential endpoints are not protected from a scoped context
Authenticated users with limited scopes can create EC2 credentials with escalated permissions, potentially gaining global admin privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-12689?
CVE-2020-12689 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 6 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. Any user authenticated within a limited scope (trust/oauth/application credential) can create an EC2 credential with an escalated permission, such as obtaining admin while the user is on a limited viewer role. This potentially allows a malicious user to act as the admin on a project another user has the admin role on, which can effectively grant that user global admin privileges.
Weakness: CWE-269
Which versions are affected by CVE-2020-12689?
5 open source packages ship an affected version, including keystone. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
keystone PyPI | All versions | 15.0.1 |
keystone PyPI | All versions | 15.0.1 |
keystone PyPI | All versions | 15.0.1 |
keystone PyPI | From 16.0.0 | 16.0.1 |
keystone PyPI | From 16.0.0 | 16.0.1 |
Products include Canonical Ubuntu Linux, Openstack Keystone.
How do I fix CVE-2020-12689?
Upgrade keystone to a fixed version for your release line: 15.0.1 or 16.0.1.
Is CVE-2020-12689 being exploited?
There is no known exploitation of CVE-2020-12689 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2020-12689, GHSA-chgw-36xv-47cw, PYSEC-2020-53, UBUNTU-CVE-2020-12689.