# CVE-2020-12690: Insufficient Session Expiration in OpenStack Keystone

> OpenStack Keystone ignores OAuth1 role restrictions, granting tokens all creator roles and enabling unintended privilege escalation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-12690, GHSA-6m8p-x4qw-gh5j, PYSEC-2020-54, UBUNTU-CVE-2020-12690

## What is CVE-2020-12690?

CVE-2020-12690 is a high-severity vulnerability in n/a, published on 6 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. The list of roles provided for an OAuth1 access token is silently ignored. Thus, when an access token is used to request a keystone token, the keystone token contains every role assignment the creator had for the project. This results in the provided keystone token having more role assignments than the creator intended, possibly giving unintended escalated access.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2020-12690?

5 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | From 16.0.0.0rc1 | 16.0.0 |
| `keystone` | PyPI | From 16.0.0.0rc1 | 16.0.0 |

Products: Openstack Keystone.

## How do I fix CVE-2020-12690?

Upgrade keystone to a fixed version for your release line: 15.0.1 or 16.0.0.

## Is CVE-2020-12690 being exploited?

There is no known exploitation of CVE-2020-12690 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)
- [CVE-2015-7546](https://insights.sbomify.com/CVE-2015-7546/): OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12690 and fix it if it is affected.

What it is: CVE-2020-12690 is a high-severity vulnerability in n/a, published on 6 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-12690 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected from 16.0.0.0rc1; fixed in 16.0.0
- keystone (PyPI): affected from 16.0.0.0rc1; fixed in 16.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12690/ (Markdown: https://insights.sbomify.com/CVE-2020-12690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12690
- OSV: https://osv.dev/vulnerability/CVE-2020-12690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12690/
Summaries are generated and may contain mistakes; the official description above is the record.
