# CVE-2020-12691: OpenStack Keystone V3 /credentials endpoint policy logic allows to change credentials owner or target project ID

> Authenticated users can escalate privileges to global admin by manipulating EC2 credentials, requiring an upgrade to OpenStack Keystone.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-12691, GHSA-4427-7f3w-mqv6, PYSEC-2020-55, UBUNTU-CVE-2020-12691

## What is CVE-2020-12691?

CVE-2020-12691 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 6 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. Any authenticated user can create an EC2 credential for themselves for a project that they have a specified role on, and then perform an update to the credential user and project, allowing them to masquerade as another user. This potentially allows a malicious user to act as the admin on a project another user has the admin role on, which can effectively grant that user global admin privileges.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-12691?

5 open source packages ship an affected version, including keystone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | All versions | 15.0.1 |
| `keystone` | PyPI | From 16.0.0 | 16.0.1 |
| `keystone` | PyPI | From 16.0.0 | 16.0.1 |

Products: Canonical Ubuntu Linux, Openstack Keystone.

## How do I fix CVE-2020-12691?

Upgrade keystone to a fixed version for your release line: 15.0.1 or 16.0.1.

## Is CVE-2020-12691 being exploited?

There is no known exploitation of CVE-2020-12691 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12691 and fix it if it is affected.

What it is: CVE-2020-12691 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 6 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-12691 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected all versions; fixed in 15.0.1
- keystone (PyPI): affected from 16.0.0; fixed in 16.0.1
- keystone (PyPI): affected from 16.0.0; fixed in 16.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12691/ (Markdown: https://insights.sbomify.com/CVE-2020-12691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12691
- OSV: https://osv.dev/vulnerability/CVE-2020-12691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12691/
Summaries are generated and may contain mistakes; the official description above is the record.
