# CVE-2020-12827: MJML vulnerable to path traversal

> An attacker can read arbitrary files via path traversal in the mj-include directive of the MJML email library.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4hch-r9xf-6vfr

## What is CVE-2020-12827?

CVE-2020-12827 is a high-severity path traversal vulnerability in n/a, published on 17 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MJML prior to 4.6.3 contains a path traversal vulnerability when processing the mj-include directive within an MJML document.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-12827?

2 open source packages ship an affected version, including mjml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mjml` | npm | All versions | 4.6.3 |
| `mjml` | npm | All versions | 4.6.3 |

Products: Mjml Mjml.

## How do I fix CVE-2020-12827?

Upgrade mjml to 4.6.3 or later.

## Is CVE-2020-12827 being exploited?

There is no known exploitation of CVE-2020-12827 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-12827 and fix it if it is affected.

What it is: CVE-2020-12827 is a high-severity path traversal vulnerability in n/a, published on 17 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-12827 in the wild and no public exploit code.

Affected packages and fixed versions:
- mjml (npm): affected all versions; fixed in 4.6.3
- mjml (npm): affected all versions; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-12827/ (Markdown: https://insights.sbomify.com/CVE-2020-12827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-12827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-12827
- OSV: https://osv.dev/vulnerability/CVE-2020-12827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-12827/
Summaries are generated and may contain mistakes; the official description above is the record.
