# CVE-2020-13092: scikit-learn Deserialization of Untrusted Data

> Attackers can execute arbitrary commands via malicious files loaded by scikit-learn's joblib.load function, which is documented as unsafe.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-13092, GHSA-jjw5-xxj6-pcv5, PYSEC-2020-107

## What is CVE-2020-13092?

CVE-2020-13092 is a critical unsafe deserialization vulnerability in n/a, published on 15 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

scikit-learn (aka sklearn) through 0.23.0 can unserialize and execute commands from an untrusted file that is passed to the joblib.load() function, if __reduce__ makes an os.system call. NOTE: third parties dispute this issue because the joblib.load() function is documented as unsafe and it is the user's responsibility to use the function in a secure manner

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-13092?

3 open source packages ship an affected version, including scikit-learn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scikit-learn` | PyPI | All versions to 0.23.0 | None |
| `scikit-learn` | PyPI | All versions to 0.23.0 | None |
| `scikit-learn` | PyPI | All versions | 0.23.1 |

Products: Scikit-Learn Scikit-Learn.

## How do I fix CVE-2020-13092?

Upgrade scikit-learn to 0.23.1 or later.

## Is CVE-2020-13092 being exploited?

There is no known exploitation of CVE-2020-13092 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-28975](https://insights.sbomify.com/CVE-2020-28975/): scikit-learn Denial of Service (high 7.5)
- [CVE-2024-5206](https://insights.sbomify.com/CVE-2024-5206/): Sensitive Data Leakage in sklearn.feature_extraction.text.TfidfVectorizer in scikit-learn/scikit-learn (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-13092 and fix it if it is affected.

What it is: CVE-2020-13092 is a critical unsafe deserialization vulnerability in n/a, published on 15 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-13092 in the wild and no public exploit code.

Affected packages and fixed versions:
- scikit-learn (PyPI): affected all versions up to 0.23.0; no fix listed
- scikit-learn (PyPI): affected all versions up to 0.23.0; no fix listed
- scikit-learn (PyPI): affected all versions; fixed in 0.23.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-13092/ (Markdown: https://insights.sbomify.com/CVE-2020-13092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-13092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-13092
- OSV: https://osv.dev/vulnerability/CVE-2020-13092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-13092/
Summaries are generated and may contain mistakes; the official description above is the record.
