CVE-2020-13269 Cross-site scripting in GitLab
Reflected XSS in GitLab Static Site Editor allows arbitrary JavaScript execution, requiring a patch to prevent client-side attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13269?
CVE-2020-13269 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 10 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A Reflected Cross-Site Scripting vulnerability allowed the execution of arbitrary Javascript code on the Static Site Editor in GitLab CE/EE 12.10 and later through 13.0.1
Weakness: CWE-79
Which versions are affected by CVE-2020-13269?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.10.0 | 12.10.7, 13.0.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13269?
Upgrade gitlab to a fixed version for your release line: 12.10.7 or 13.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13269 being exploited?
There is no known exploitation of CVE-2020-13269 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13269, GHSA-7579-pf64-fxw7.