CVE-2020-13271 Cross-site scripting in GitLab

Medium 6.1 Published Updated

Stored XSS in GitLab blobs API allows arbitrary JavaScript execution, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13271?

CVE-2020-13271 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 10 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A Stored Cross-Site Scripting vulnerability allowed the execution of arbitrary Javascript code in the blobs API in all previous GitLab CE/EE versions through 13.0.1

Weakness: CWE-79

Which versions are affected by CVE-2020-13271?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions12.9.8, 12.10.7, 13.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2020-13271?

Upgrade gitlab to a fixed version for your release line: 12.9.8, 12.10.7 or 13.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13271 being exploited?

There is no known exploitation of CVE-2020-13271 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13271, GHSA-h6w2-q947-gwv4, UBUNTU-CVE-2020-13271.

Is CVE-2020-13271 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free