CVE-2020-13273 Denial of service in GitLab
Attackers can exhaust system resources in GitLab, causing a denial of service for the platform.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13273?
CVE-2020-13273 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Denial of Service vulnerability allowed exhausting the system resources in GitLab CE/EE 12.0 and later through 13.0.1
Which versions are affected by CVE-2020-13273?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.0.0 | 12.9.8, 12.10.7 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13273?
Upgrade gitlab to a fixed version for your release line: 12.9.8 or 12.10.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-13273 being exploited?
There is no known exploitation of CVE-2020-13273 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13273, GHSA-3xg5-7r36-7647.