CVE-2020-13274 Denial of service in GitLab

High 7.5 Published Updated

Attackers can cause denial of service via memory exhaustion by uploading malicious artifacts to GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13274?

CVE-2020-13274 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A security issue allowed achieving Denial of Service attacks through memory exhaustion by uploading malicious artifacts in all previous GitLab versions through 13.0.1

Which versions are affected by CVE-2020-13274?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions12.9.8, 12.10.7, 13.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2020-13274?

Upgrade gitlab to a fixed version for your release line: 12.9.8, 12.10.7 or 13.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13274 being exploited?

There is no known exploitation of CVE-2020-13274 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13274, GHSA-p7jp-3g8m-8m7m, UBUNTU-CVE-2020-13274.

Is CVE-2020-13274 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free