CVE-2020-13280 Denial of service in GitLab

Medium 6.5 Published Updated

An attacker can cause memory exhaustion and denial of service in GitLab by triggering excessive logging of invite email errors.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13280?

CVE-2020-13280 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

For GitLab before 13.0.12, 13.1.6, 13.2.3 a memory exhaustion flaw exists due to excessive logging of an invite email error message.

Weakness: CWE-400

Which versions are affected by CVE-2020-13280?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions13.0.12, 13.1.6, 13.2.3

Products include Gitlab Gitlab.

How do I fix CVE-2020-13280?

Upgrade gitlab to a fixed version for your release line: 13.0.12, 13.1.6 or 13.2.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13280 being exploited?

There is no known exploitation of CVE-2020-13280 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13280, GHSA-4839-fmx8-4hrv, UBUNTU-CVE-2020-13280.

Is CVE-2020-13280 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free