CVE-2020-13281 Denial of service in GitLab
Attackers can cause a denial of service in GitLab via the project import feature, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13281?
CVE-2020-13281 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
For GitLab before 13.0.12, 13.1.6, 13.2.3 a denial of service exists in the project import feature
Weakness: CWE-400
Which versions are affected by CVE-2020-13281?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 8.9.0 | 13.0.12, 13.1.6, 13.2.3 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13281?
Upgrade gitlab to a fixed version for your release line: 13.0.12, 13.1.6 or 13.2.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-13281 being exploited?
There is no known exploitation of CVE-2020-13281 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13281, GHSA-6hf8-hv66-q62p.