CVE-2020-13284 Auth bypass in GitLab
Attackers can bypass API authorization using outdated CI job tokens in GitLab, potentially accessing unauthorized resources.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13284?
CVE-2020-13284 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. API Authorization Using Outdated CI Job Token
Weakness: CWE-863
Which versions are affected by CVE-2020-13284?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.3.0 | 13.1.10, 13.2.8, 13.3.4 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13284?
Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2020-13284 being exploited?
There is no known exploitation of CVE-2020-13284 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13284, GHSA-qcj8-gp4q-v8r2, UBUNTU-CVE-2020-13284.