CVE-2020-13285 Cross-site scripting in GitLab
An attacker can execute arbitrary scripts in the victim's browser via a cross-site scripting vulnerability in the issue reference number tooltip.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13285?
CVE-2020-13285 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 13 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
For GitLab before 13.0.12, 13.1.6, 13.2.3 a cross-site scripting (XSS) vulnerability exists in the issue reference number tooltip.
Weakness: CWE-79
Which versions are affected by CVE-2020-13285?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.9.0 | 13.0.12, 13.1.6, 13.2.3 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13285?
Upgrade gitlab to a fixed version for your release line: 13.0.12, 13.1.6 or 13.2.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13285 being exploited?
There is no known exploitation of CVE-2020-13285 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13285, GHSA-3qvh-rmmw-6m99.