CVE-2020-13288 Cross-site scripting in GitLab
An attacker can inject malicious scripts into the CI/CD Jobs page, potentially executing code or hijacking user sessions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13288?
CVE-2020-13288 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 12 Aug 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In GitLab before 13.0.12, 13.1.6, and 13.2.3, a stored XSS vulnerability exists in the CI/CD Jobs page
Weakness: CWE-79
Which versions are affected by CVE-2020-13288?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.0.0 | 13.0.12, 13.1.6, 13.2.3 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13288?
Upgrade gitlab to a fixed version for your release line: 13.0.12, 13.1.6 or 13.2.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-13288 being exploited?
There is no known exploitation of CVE-2020-13288 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13288, GHSA-r68r-r23h-fpvc.