CVE-2020-13300 Security feature bypass in GitLab
Attackers can change OAuth authorization scopes without user consent during the flow, bypassing security controls in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-13300?
CVE-2020-13300 is a high-severity vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
GitLab CE/EE version 13.3 prior to 13.3.4 was vulnerable to an OAuth authorization scope change without user consent in the middle of the authorization flow.
Weakness: CWE-863
Which versions are affected by CVE-2020-13300?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.3.0 | 13.3.4 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13300?
Upgrade gitlab to 13.3.4 or later.
Is CVE-2020-13300 being exploited?
There is no known exploitation of CVE-2020-13300 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13300, GHSA-69vx-f9hq-xc87, UBUNTU-CVE-2020-13300.