CVE-2020-13302 Auth bypass in GitLab

Low 3.8 Published Updated

GitLab failed to revoke sessions properly, allowing attackers to access accounts using old passwords.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13302?

CVE-2020-13302 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. Under certain conditions GitLab was not properly revoking user sessions and allowed a malicious user to access a user account with an old password.

Weakness: CWE-613

Which versions are affected by CVE-2020-13302?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.11.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13302?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-13302 being exploited?

There is no known exploitation of CVE-2020-13302 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13302, GHSA-h42v-738f-q57f, UBUNTU-CVE-2020-13302.

Is CVE-2020-13302 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free