CVE-2020-13304 Weak cryptography in GitLab
Weak random number generation in GitLab allows attackers to predict 2FA codes and maintain unauthorized access to user accounts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-13304?
CVE-2020-13304 is a low-severity vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. Same 2 factor Authentication secret code was generated which resulted an attacker to maintain access under certain conditions.
Weakness: CWE-330
Which versions are affected by CVE-2020-13304?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 1.0.0 | 13.1.10, 13.2.8, 13.3.4 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-13304?
Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.
Is CVE-2020-13304 being exploited?
There is no known exploitation of CVE-2020-13304 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-13304, GHSA-w7hh-546g-p758, UBUNTU-CVE-2020-13304.