CVE-2020-13306 Denial of service in GitLab

Low 3.7 Published Updated

Attackers can cause denial of service in GitLab by abusing the Webhook feature due to missing rate limits.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13306?

CVE-2020-13306 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab Webhook feature could be abused to perform denial of service attacks due to the lack of rate limitation.

Weakness: CWE-770

Which versions are affected by CVE-2020-13306?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13306?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13306 being exploited?

There is no known exploitation of CVE-2020-13306 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13306, GHSA-jcrh-hfqv-cr47, UBUNTU-CVE-2020-13306.

Is CVE-2020-13306 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free