CVE-2020-13307 Security feature bypass in GitLab

Low 3.8 Published Updated

GitLab failed to revoke active sessions when enabling two-factor authentication, allowing attackers to maintain unauthorized access to user accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13307?

CVE-2020-13307 is a low-severity vulnerability in Gitlab Gitlab, published on 15 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab was not revoking current user sessions when 2 factor authentication was activated allowing a malicious user to maintain their access.

Weakness: CWE-613

Which versions are affected by CVE-2020-13307?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13307?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Is CVE-2020-13307 being exploited?

There is no known exploitation of CVE-2020-13307 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13307, GHSA-4rmw-pmhj-w226, UBUNTU-CVE-2020-13307.

Is CVE-2020-13307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free