CVE-2020-13308 Denial of service in GitLab

Low 2.7 Published Updated

Attackers can deny service to users without 2FA by inviting them to projects enforcing 2FA inheritance, locking them out of GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13308?

CVE-2020-13308 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 15 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. A user without 2 factor authentication enabled could be prohibited from accessing GitLab by being invited into a project that had 2 factor authentication inheritance.

Weakness: CWE-281

Which versions are affected by CVE-2020-13308?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13308?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13308 being exploited?

There is no known exploitation of CVE-2020-13308 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13308, GHSA-6fvc-pc2f-vcp7, UBUNTU-CVE-2020-13308.

Is CVE-2020-13308 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free