CVE-2020-13310 Denial of service in GitLab

Medium 6.5 Published Updated

Attackers can crash the GitLab runner process by sending malformed queries, causing a denial of service for CI/CD pipelines.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13310?

CVE-2020-13310 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 14 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was discovered in GitLab runner versions before 13.1.3, 13.2.3 and 13.3.1. It was possible to make the gitlab-runner process crash by sending malformed queries, resulting in a denial of service.

Which versions are affected by CVE-2020-13310?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.013.1.3, 13.2.3, 13.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2020-13310?

Upgrade gitlab to a fixed version for your release line: 13.1.3, 13.2.3 or 13.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13310 being exploited?

There is no known exploitation of CVE-2020-13310 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13310, GHSA-cfp6-wq22-gv3m, UBUNTU-CVE-2020-13310.

Is CVE-2020-13310 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free