CVE-2020-13314 Cross-site scripting in GitLab

Low 3.7 Published Updated

Attackers can inject malicious scripts into GitLab Omniauth error messages, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13314?

CVE-2020-13314 is a low-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab Omniauth endpoint allowed a malicious user to submit content to be displayed back to the user within error messages.

Which versions are affected by CVE-2020-13314?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.1.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13314?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13314 being exploited?

There is no known exploitation of CVE-2020-13314 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13314, GHSA-cfhj-wmq5-2vrv, UBUNTU-CVE-2020-13314.

Is CVE-2020-13314 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free