CVE-2020-13315 Denial of service in GitLab

Low 3.7 Published Updated

An attacker can cause a denial of service by requesting excessive results on the profile activity page in GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13315?

CVE-2020-13315 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. The profile activity page was not restricting the amount of results one could request, potentially resulting in a denial of service.

Which versions are affected by CVE-2020-13315?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.4.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13315?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-13315 being exploited?

There is no known exploitation of CVE-2020-13315 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13315, GHSA-hcwc-2gm5-v9g6, UBUNTU-CVE-2020-13315.

Is CVE-2020-13315 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free