CVE-2020-13317 Missing authorization in GitLab

Medium 6.5 Published Updated

A maintainer can delete a repository due to insufficient checks in the GraphQL API, requiring GitLab administrators to apply security patches.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-13317?

CVE-2020-13317 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 14 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8, and 13.3.4. An insufficient check in the GraphQL api allowed a maintainer to delete a repository.

Weakness: CWE-20

Which versions are affected by CVE-2020-13317?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.6.013.1.10, 13.2.8, 13.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2020-13317?

Upgrade gitlab to a fixed version for your release line: 13.1.10, 13.2.8 or 13.3.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2020-13317 being exploited?

There is no known exploitation of CVE-2020-13317 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13317, GHSA-qxgw-h378-xhrw, UBUNTU-CVE-2020-13317.

Is CVE-2020-13317 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free