CVE-2020-13328 Cross-site scripting in GitLab

Medium 4.8 Published Updated

Attackers can inject malicious scripts via the PyPi files API, potentially leading to session hijacking or code execution in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-13328?

CVE-2020-13328 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 29 Sep 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting versions prior to 13.1.2, 13.0.8 and 12.10.13. GitLab was vulnerable to a stored XSS by using the PyPi files API.

Weakness: CWE-79

Which versions are affected by CVE-2020-13328?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.0.012.10.13, 13.0.8, 13.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2020-13328?

Upgrade gitlab to a fixed version for your release line: 12.10.13, 13.0.8 or 13.1.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-13328 being exploited?

There is no known exploitation of CVE-2020-13328 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-13328, GHSA-h9jj-wh2c-fq64, UBUNTU-CVE-2020-13328.

Is CVE-2020-13328 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free